Auto mode switching not working


#1

I’ve been having this problem since I moved Canary to a different location and I’ve been troubleshooting the problem myself but now, I’m out of ideas.

I’ll start from the beginning. When I purchased my first Canary,
I set it up at my place in Tx to test while I was there for a few weeks. I moved the Canary to my place in La and evidently I did something wrong.
I have two locations set up through the app now and I can’t get rid of one of them. I have the Canary set up for the second location plus just installed a Flex yesterday for the same location. When trouble shooting, I was using the app on three devices, one of those devices stayed in Tx. I figured that since I had the app on a device that wasn’t with me, it was causing the problem. Since then, I deleted the app off of all devices except one, my iPhone.

I’ve did everything mentioned in troubleshooting that I could find online including deleting the app on the only device left and reinstalling the app. It still shows that “You are not at home”.
I have both Canary’s set for auto switching.

I had originally set Canary up on a different phone. I have since switched phones from an iPhone 5 to an iPhone 7.

I remember that I had to hook the yellow communications cable up to the first phone during setup.
Do I need to do that again for the second phone? and if so, how do I get to it?

I can set Canary to private while at home and that works but auto switching would be nice to have back.


#2

@Sam Just FYI, support needs to delete locations from the app, so let me know and I’ll go ahead and do that. Letting users do that themselves would be a solid feature request.

I checked your account, and from what I can see, there’s no obvious reason for why auto mode switching isn’t working. I might eventually ask you to contact support to discuss some personal data that will help us understand, but there are a few things we can look at first

1. What’s your cellular signal like in the new location? If it’s weaker than the old location, this could be a contributor.

2. Did you manually enter your new address, or did you use the green arrowhead (GPS icon) in settings to set your location? I’d recommend resetting your geofence using GPS instead of typing in your address manually, then rebooting your phone. We have a guide to updating your address here:

Let me know if any of that helps!


#3

Hi Pete. Sorry for the late reply. I’ve been on the road a lot since early last week.
If you can delete the other location, I’d appreciate it. You will notice that I have N/A in several of the fields of the location that needs to be deleted.

Yes, I typed in the address of the location that I am using now.
The cellular signal is weaker at the new location.

I’ll try to reset the geofence once I return home again in a couple weeks.


#4

Hey @Sam, I’ve taken care of that location for you. You may need to log out and back into the app to see that change reflected.

Let me know how it goes once you get back home. Before you update your geofence, just make sure to connect to Wi-Fi first. I’d also open Apple Maps on your phone to verify Apple’s margin of error by the diameter of the faint blue circle around your location.

Just linking this thread as it covers some of the same principles.


#5

Thanks a bunch Pete!!!


#6

Happy to help, Sam! Let me know if you continue to have problems after trying the above.


#7

I have little bit different issue. Here is situation: my wife (member of our Canary device) has arrived at home (I was in our flat) but I saw she is not at home on Canary main screen (her avatar was without home icon). Here is dump of Timeline: 7:36 left home -> 15:33 arrived home -> 15:33 left home. So, we were together at home but in Canary Timeline my wife left home 15:33. Change of her status appeared in Time line only at 15:45! She was throughout (from 15:33) with me at home actually. I have investigated the Timeline history and I have found similar situation couple days ago but in opposite situation, Tmeline dump here: 9:31 left home -> 9:31 arrived home -> 9:32 left home. Finally she arrived home at 10:18. I was throughout at home. So, I can see some issue in case when the same time for left/arrived home is logged into Timeline (and vice versa).