Auto-switching hasn't worked in a month

Continuing the discussion from Auto switching isn't working, even with time scheduling:

On July 29, 2022 everytime I opened the app it crashed immediately so I deleted and reinstalled. After that, auto-switching hasn’t worked. I spent days trying everything in the help article and got nowhere. I contacted support on August 11 saying I had already tried all of their suggestions. On August 16, I was told to try a bunch of stuff that I had already done and then in the next email support confirmed that there were 2 device tokens active and directed me on how to fix that. It didn’t work but there is now only 1 device token. On August 20, I was told I would be escalated to the specialists. On August 24, I was told to update to the latest version of the app, which I had already done. On August 26, I was told to follow the steps to adjust my geofence position (which I had done before). I responded that when I click on the green arrow to find my current location, that the app thinks I’m about 4 miles away. (I’ve actually checked this several times since then and sometimes it’s a block away and sometimes it’s miles and it’s not consistent in where it thinks I am.)
I have not gotten a response from support since but I have sent more than one request for a follow-up email. It’s now been more than a month since it has switched modes other than manually and support won’t help me. Does anyone know how to fix this problem? Or what other cameras I can buy that will auto-switch?