Auto switching isn't working, even with time scheduling


#1

Hi,

Another issue I am having with the Canary is that the switching doesn’t work. I have a Samsung S6 and keep both the app open and location services enabled. When I leave in the mornings and get to work, it still is in home mode, and has been like this all week.

I’ve also been testing setting up night mode, but it never enables. The only way I can switch is by doing it manually.


Auto Mode Switch not working
Won't come out of Night Mode on its own
#2

Fixed by restarting my phone and resetting the location. It would be better if the auto switching was done on the canary side by detecting if my phone is on the local network, rather than the app running all the time, and the battery hungry location services!


#3

Hi Dave,

I am having the same problem, except it doesn’t even go into night mode in the first place. Also it doesn’t switch to away mode when I leave the house. I read other posts but still can’t get it to work despite my best efforts. Is there anything else I can try?

Thanks

Joe

Edit: It constantly says I am not home. I have checked the pin on the map is in the correct location. Could it be that my apartment is new build and the post code doesn’t exist on any mapping service yet?


#4

I managed to fix the problem with auto switching by resetting the location and restarting my phone. Disappointing to learn that it relies on the app on my phone to be running, and with location services enabled to switch, instead of just simply looking at devices on the local network to determine if my phone is connected to it or not.


#5

Is there any fix for Android? Night mode doesn’t work at all.


#6

Hi @JoeyJoe,

I went ahead and merged your comments into one post since they are all related to the same issue.

We use several services to determine your location in order to achieve the highest accuracy. You might be interested in this Help Center article which goes into more detail about how this works:

How does Canary know when I’m Home or Away?

Are you still having trouble, or was everything resolved with rebooting and enabling location services?


#7

Yes, the latest version 2.4.1 includes the fix for night mode.