Canary app no longer displays Home Health info


#1

I have been having this problem for weeks but am only just now getting around to reporting it. Sorry for the delay. The Canary app on my iPhone no longer displays the home health information. It just sits there and continuously flashes the “Loading HomeHealth” message. If I tap the “HomeHealth” message on the app, it opens the usually HomeHealth reports, but everything is blank. I have not bee able to review my HomeHealth information for weeks.

The new online browser view version of Canary shows the current HomeHealth information. So, I know the sensors are actually working. Unfortunately, the browser version does not have any way to view HomeHealth history. It only shows the current readings.

I need to be able to review the HomeHealth history. For example, right now, the browser feed is showing that my air quality is “Very Abnormal”. However, I have no way to see what time my air quality jumped up to “Very Abnormal.” I’d like to review the history to see if it corresponds to when I open/close the windows in my house, or when I am cooking dinner, or if there is something else going on that is causing air quality issues in my home.


#2

Hey @RobbW,

Thanks for the report. This sound like it might be an issue with the app and not the device as you said, however the first two steps there I’d suggest are to unplug and restart your Canary AIO, and re-install the app. Have you given that a try?

If that doesn’t do it, I’d suggest submitting a ticket directly to Canary.


#3

Thanks, @Zev! Deleting the app and reinstalling cleared up the issue with the HomeHealth issue no longer being displayed.


#4

Same. About two months. Was just low on list.


#5

@Brianc,

Have you also tried deleting and re-installing your app? That seemed to clear it up for @RobbW.


#6

It did. Forgot password, reset, download. Hopefully don’t have to again. :slight_smile:


#7

Great, glad to hear!


#8

Sadly, my iPhone XS Max also doesn’t display the Home Health. After reinstalling he app, it displays the correct figures after login until I activate the Location Tracking, then it switches back to “loading Health data”.

I have reinstalled twice and it doesn’t change. Help please :frowning:


#9

This is a recording of the problem. If I restart the tutorial, the data is displayed correctly. After a few seconds, it vanishes. https://www.dropbox.com/s/s80rle8es6h76ro/canaryhomehealth.MP4?dl=0


#10

Hey @Magnus55, this is definitely an unexpected behavior. I would suggest that you submit this as a support ticket to Canary so they can get it into their bug tracking.

You can submit a ticket to Canary’s support team so that they can take a look at your specific device(s) and assist in figuring this out.

There are a few different ways you can contact support if you would prefer a faster response during business hours, you can find details about that here.


A few tips when submitting your ticket:

  • Include the email you use on your Canary login as your contact email so Canary can find your account quickly.
  • If you have multiple Canary devices, include this information and detail which models you are having issue with.
  • Include any pictures or videos that might help diagnose the issue you are having.
  • Be as detailed and clear as you can in your description to help Canary diagnose your issue.
  • Say what you have already tried and how you did it, this may help speed up your time to a fix.
  • Include a link to this topic if it contains additional information from other users that might help Canary.