Canary Flex battery doesn't charge / charges slowly


#1

Hi my Flex Battery is not charging. I’ve had this plugged in for more than a hour and the status is not changing. Is there a special way to charge the battery thanks in advance. location is indoor


Battery display
Canary Flex won't charge
#2

Hey @tony535,

If your Canary Flex is actively recording, especially if it’s using night vision, it may take a very long time to charge. You may want to try setting your Canary Flex to private as this will shut off the camera and provide it with the fastest charge. I’d give it a few hours on the charger as well before looking for a change in the battery level.

Let us know if you’re still having trouble after trying this!


#3

I had the same issue until I contacted support and they also recommended turning it to private. I did and the battery charges much faster.


#4

Hi I’ve charged my canary flex over night however the display on my app looks like the battery has not fully charged up
I have 2 questions.

  1. I have only just had my flex and I’ve put it straight on charge, how long should this take ?

2.is there any way I can change the the display on the app so it shows the battery percentage not just the battery image ?

Thank you for your help


#5

Hi @johnsond28,

I went ahead and merged your post in with an existing thread on this issue.

Typically the Canary Flex will take a few hours to charge, but this can vary. Recording, especially in night vision, uses a lot of power so the Flex will charge very slowly if it is actively recording in a dark environment while you’re trying to charge it. For the fastest charge, I’d recommend switching your Canary Flex into private so it stops recording and all resources are put directly towards charging the battery.

I’d also check out this Help Center article for more troubleshooting steps for a slowly charging battery:

Why does it take so long to charge the battery on my Flex?

As for your second question, there isn’t an option to display a percentage for the battery at this time.

Hope that helps, let us know if you have any other questions!


#6

I am not sure if this is the same issue, but my Flex seems to be having similar issue re-charging. I have read through the various support articles and confirmed that it is in “Private” mode as well as that the cable and power are connected. However, the Flex seems to go on “PWR” mode for a few minutes before going off-line at which time it does not seem to be charging. I believe this is only the 2nd or 3rd time I am charging the Flex. Has anyone any recommendations /suggestions?


#7

Hello,

Both of my Canary Flex cameras have been charging now for almost 48 hours and the battery gauge has not moved. One camera is a little over a year old the second was just purchased within the past 3 months. HELP!


#8

Hi @paulmnly,

I went ahead and merged your post into an existing topic on this.

I’d recommend checking this Help Center article for troubleshooting suggestions:

Why does it take so long to charge the battery on my Flex?

If that doesn’t help, please open a ticket with our support team and they’d be happy to help!


#9

4 posts were split to a new topic: Option to put Flex into private mode when charging


#10

Hi folks,

I having similar problems with my flex also. I think I’ve tried everything in this forum and it still won’t charge. I’ve contacted support and tried everything they have suggested too, same result. Their latest recommendation is to set it to private mode, which I’ve done many times, but no change. I haven’t heard from support anymore…

I’ve had the flex plugged in since I got it three weeks ago and it simply will not take a charge. I even shut it off completely for 24hrs and tried to charge it that way… When I did that, the battery level actually went from 50% to 25%.

I’m stumped, been using battery powered devices for decades and this one defies logic… while plugged in, it actually loses battery power.

Help! Thanks


#11

I am also having issues charging both my flex cameras. I have had these since January, and I have tired charging them while powered down, and in private mode and it either takes a 48 hour period to charge or I cannot get a full charge at all. Yesterday morning at 7am, I took both cameras down to charge. I placed them in private mode. This morning, a full 24 hours later, I have a full charge on one camera, the second is only at around 80%. Why the inconsistencies? Although I’m happy with the system as a whole, these camera’s batteries are terrible and are the weakest point in the system.


Option to put Flex into private mode when charging
#13

Having the same issue with my Canary Flex. Nothing seems to work. Tried contacting support who recommended I change chargers. Did that, worked once and doesn’t work anymore. Help!


#14

Your best bet is going to continue to talk to support directly. It’s odd that your device is having this issue, but the best way to resolve is going to be to file a new ticket and reference the old one.


#15

I am having the exact same issue with both my devices. I thought it may have been the USB cables or adapters but this is hit and miss. I am also not convinced the application is reporting the correct battery status either. Have any improvements been made here? I tried charing one device while powered down, only to restart it later with a lower battery level…is this product really that crap?


#16

Mine is taking forever to charge and then it just died this morning while plugged in. All summer I had no issues plugged in and it held a charge while operating. Its winter now and its acting up. Hope this isn’t a fair weather camera. So, before I thru in the towel, I took the lead cord off and moved the camera so it would reach my outside electrical socket. I think the cord is to short anyway. I know, its just for charging. So, I left the lead cord off, plugged it in and wala, its started charging right away ( the lead cord is new) it took about 9 hours to charge. The camera lasts about 2 days at best before it has to be plugged in and yes, I’ve tried all the motion/recording settings available for the least amount of use possible, still not having much luck


#17

I have 2 Flex’s and both are having charging issues. Both Flex’s stay plugged in 24/7, both Flex’s are outside. When I chat with support they tell me to continue the conversation via email. The response time for that form of interaction hasn’t been good at all. I love the system, but these power issues are not good. So, I have a Flex that won’t turn on and it won’t charge, please help.


#18

Hi Jeff,

With any cases that may require a warranty replacement of the hardware it does require that the case be reviewed and approved by one of our Tier 2 Specialists. I can see that someone has already reviewed and approved the replacement for your case. An agent will be reaching out shortly to gather the relevant information to move forward with the replacement process.

Please let me know if you have any additional questions or concerns.


#19

Hello Sean,

Thank you for the quick response. I look forward to be up and running soon.


#20

That article did the trick. Powering down my flex, which I had no idea you could do, and powering it back up started my flex charging again. Thank You!:smiley::+1:


#21

Glad to hear things are working for you again!