Canary Flex Connectivity Drops


#1

I own 3 Canary Flex devices and have had issues with all of them while they are on battery only. Here are the details:

Both Canary Flex devices are mount outside of my house where the Wi-Fi signal is strong.
Both devices connect to my Wi-Fi network while on battery.
Shortly there after, the signal drops and both Canary’s are offline.
They intermittently reconnect; however, if I try to access them via the Canary App for iOS, they go offline.
If I plug the Canary Flex devices into power, the device remain connected to the network and they are easily accessible via the iOS app.
If all 3 are on battery, no matter where they are on the premises, they are offline.

I had an open ticket on this issue and it was suggested that there are issues with the Flex connecting to certain routers & mesh networks. A firmware update is to be issued sometime soon; however it is unknown as to when. Are there any other suggestions at this time other than isolating a network for the devices to connect to and power cycling the devices? I’ve tried both suggestions along with my own investigative work yet have not been able to resolve the issue other than by maintaining power to the devices. Thanks to anyone who can offer some support before I consider returning all of my equipment.


#2

I am having the exact same problem with the 2 Flex devices I bought yesterday. I have a strong 150mb Wi-Fi service in my house. I use a cable modem router (ARRIS Surfboard SBG6900-AC) setting 6 feet high on top of a bookshelf. When my grandchildren come over they and my adult children all have Wi-Fi devices. I sometimes have 15 devices working at the same time with no issue. So I’m thinking the Flex is the issue. I live in Las Vegas and it is about 40 degrees this morning so I don’t think it is the weather either.


#3

Glad to know I’m not the only one. So I’m assuming they work consistently when they’re plugged into power?


#4

Thanks for the feedback all. We’re investigating these connectivity issues when on battery. Our support team will reach out directly if any additional info is needed.

Dave


#5

I have the exact same problem with my Canary Flex and more. In addition, to the connectivity drops, my battery on a good week only last a week and the majority of video that is recorded can’t be played on my iPhone as I get an error message. I have been working with support for several weeks and I’m told a firmware update coming soon should fix the problem. As well as a known issue with the iPhone app in playing video. I’m hopeful but not confident, seems like the product was released way before full testing was done. I have the regular Canary inside and really enjoy it, but the Flex has way too many shortfalls.


#6

Thanks for the info! I am beginning to have the same thoughts. I bought the Flex in hopes of keeping everything under one system. The product features were great but to encounter these problems from the outset has been a let down. I hope that they do release a solid firmware update to address this issue. I’ve been wanting to deploy these cams but do not have the confidence to do so until then.

-Stephen


#7

I recently got a Canary Flex to compliment the 3 regular canary’s I have in my home. I have it sitting on my window sill looking out to the front yard of my home plugged in. Setting it up was easy enough and was running fine until it went offline. Figured it would reconnect soon but It never did. Had to manually press the connect button to trigger it to reconnect to my home wifi. The next day I noticed it went offline again. I contacted Canary customer support they said that I had to have Ports setup on my home router. I contacted Verizon FiOS and they assisted in setting that up on my main router as well as the 2 FiOS network extenders so that no matter which router it connected to, it should be fine.

Sure enough still continues to go offline. I wanted to buy another one for my backyard but id like the confidence of this device working smoothly before I invest in my soon to be 5th canary!


#8

Hi Dave, I saw that my Flex was updated to 1.04; however, the problem still exists. Was this update supposed to address the issue that several users are experiencing?


#9

@sfabay Tough to say without knowing knowing all the environmental variables with your devices and home network configuration. I would be happy to take a look at your account directly if you submit a request and reference me (Matt M) in the email. From what I know about our upcoming release schedule, you should be very pleased with the connectivity / battery improvements that we have planned over the next month related to Flex operation on battery. Thanks for continued Flex feedback all.


#10

Hi Matt,

Thanks for the reply. I’ll open another ticket and detail the issue that I still have. You may also want to refer to my previous closed tickets in advance in case I leave out any details.

-Stephen


#11

For discussion purposes any loss in connectivity between the camera and our servers will cause a camera to go offline. That could be a broken connection between the camera and the Wi-Fi router, the Wi-Fi router/modem turning off, the ISP being down/slow or Canary cloud issues. In certain cases adding a DHCP reservation for the device can help with connectivity trouble. By reserving the IP address, you make the ID static, and the server can get its address back at all times. This helps in narrowing down an issue between the device > router/modem > canary cloud.


#12

Thanks for the reply! I’ll give the Canary Flex a static IP and will reply with my findings.

Stephen Fabay


#13

Hi Guys - just come across this thread and curious to see if any of you managed to resolve the connectivity issues you are experiencing? Here is some detail on my specific problem (apologies for the long post), I have also logged an issue in relation to my problem as well.

I recently purchased two Canary Flex devices for use at home in Australia. The device installed at my Front Door has been working as expected, detecting motion events and being able to “Watch Live.” Watch Live take some time to load, but I put this down to a slower internet connection along with latency to Canary cloud services from Australia.

However, my other Flex device is not performing as expected when in battery mode (i.e. not plugged in) as it is constantly dropping the connection to my router. This is consistent regardless of the network connection being used (I have tested over 4 different networks e.g. ADSL, 3G, 4G etc). The impact of this is when the device detects a motion event it spends a significant amount of time trying to re-establish the connection with my router (white spinning light follower by the yellow pulsing light, this happens multiple time before it eventually reconnects). As a result motion events are never actually uploaded from this device. Furthermore, the “Watch Live” feature also takes much longer to work due to the same reason of the device trying to establish the connection (~3-5min for the stream to even start).

On my home router both canary devices are configured the same. The devices are assigned a static IP address; they are both connected to the 2.4GHz interface (I have also tested the 5GHz interface as well); they both route through the same higher speed WAN that only these devices use. However, no matter what I change on a network level the behaviour of this particular device is the same while the other continues to work as expected.

I should note that I have restarted the faulty device (many times) as instructed on the Canary website. I have also removed the device and added it back to my account. Same result, nothing changes. Also both devices are running the same firmeware v1.0.5.

I have spent a significant amount of time trying to troubleshoot this issue over the last 3 days. The only conclusion I can reach to explain this inconsistent behaviour is that the flex device hardware and/or software is faulty. Is there a way that I can connect to the device directly to further troubleshoot the problem (e.g. access logs) or a way to manually re-install the device firmware (I am even willing to test beta release of firmware versions if that is even possible)?

Anyway, hope to get this resolved quickly as I don’t enjoy spending +$250AUD on something that does not work as advertised.

Thanks,
Matt


#14

Hi Matt!

The problem still exists for me primarily when I have the devices on battery mode. When plugged into power, the problem goes away. From what I’m being told, the Flex conserves power in battery mode and only connects to the router when called upon. In addition, the upload speed that the Canary staff is seeing from there end, under performs the prerequisite of a 1 MB upload. I find this hard to believe or understand because if its plugged in, the Wi-Fi speed remains the same regardless yet that is what I’m being told. What I would do is ask Canary to report to you your upload speeds for each device and go from there. Either that or find a way to deliver power to them consistently without having to rely on its battery feature.


#15

Thanks for the reply Stephen, will see what Canary come back with for my support ticket.

I would almost be able to accept using power as a temporary solution if the behaviour was consistent between both my devices and a firmware update could address the issue. However, my concern is the behaviour between the two devices is far from consistent and there is most likely a hardware fault with the device. The main selling point for me was outdoor use and long battery life. It does not help when either of these features cannot be used…

Will keep you posted if I have any success

Cheers,
Matt


#16

Hi @msardi23,

You might want to check my response to this post for more information on why you would be experiencing issues using Watch Live with Canary cameras installed in Australia. At this time users in Australia may not be able to use this feature due to the distance from our servers.

As for the issues with your Canary Flex’s connectivity, I’d need a little more information about your network to assist. Would you mind sharing the brand name and model number of your wireless router? If you use any wireless extenders or boosters please also share the make and model of those devices and whether the Canary Flex connects to them.


#17

Hi Angie! Thanks for chiming in on this thread. He is currently not the only one experiencing this as my thread contains others who exhibit the same problem while on battery mode. I had a ticket open; however, they related the issue to my upload speed. I am having a hard time believing that since when plugged in, the devices work fine, considering that the upload speed remains the same. Yes, I understand that while in battery mode, they conserve power but they should be able to resume normal functionality when called upon. I have a Netgear N700 if that helps you troubleshoot the issue. The firmware upgrades have provided little help so far as I would like to use these completely wirelessly without having to run power to them. Thoughts? Any additional info I may provide?


#18

Hi Matt! Sorry for the late reply as I was entertaining a ticket I had created with Sarah. Regarding your suggestion, even when I place a static IP on the flex device, the device tends to drop off when strictly on battery mode. When plugged in, the device functions as expected. It was speculated by Sarah that because the devices are receiving under 1 Mb of upload speed, they will drop off; however, it doesn’t make complete sense to me. Even if the device is next to the router and unplugged, the Flex still seems to go offline more often than not. If plugged in, they stay on consistently even though the upload speed remains the same. Thoughts?


#19

Hi Angie - thanks for the response.

The issues I was describing with “Watch Live” was simply to demonstrate the inconsistent behaviour I am experiencing between my two Flex devices. One works the other does not. The same applies to motion events. One device detects events and uploads them; the other sits there with spinning white and pulsing yellow lights each time it detects an event and ultimately fails to upload this. I fully appreciate and understand the latency issues you are referring to, however if this was the root cause of the problem the behaviour should be consistent across both my Canary Flex devices - but it is not.

The router I am using is an ASUS AC68U with the latest firmware applied. The actual internet connection my Canary Flex devices use is a high speed 4G connection which has at least 50mbit download and around 20mbit upload (provided as an additional WAN through my router). Only the Flex devices use the 4G connection. I do not use any other wireless extenders or boosters. To rule out any issues with my router setup I also connected the devices directly to the 4G modem as well as multiple mobile devices (via tethering). The behaviour of this particular Flex device is the same, while the other device continues to work as expected.

Hope this helps provide some additional context.


#20

Hi @msardi23,

Thank you for sharing the details of your situation. It does sound like something unusual going on with that unit and I think it would be best handled in an email. I see you submitted a ticket and one of our Specialists will be reaching out soon to assist.