Live stream not working on Safari on OSX


#1

Is anyone else having issues with the live streaming on the latest Safari with the latest Mac OS?

When loading a stream it will look as if it is working but once it loads it just a still image that updates to another still image if there is motion on that device. I’ve tried a reset of Safari and re-installed my MacBook but unfortunately I’m still experiencing the same issue.

It works fine in Chrome, but I’m not willing to switch just for live streaming on my laptop. I’m also having problems on a Windows 10 PC with Chrome that is having the same issue, tried reseting Chrome on it and a re-install but no change.

I have absolutely no problems streaming on mobile though.

Any helps or ideas would be appreciated!


#2

Hey @JayTheBearded I just tested it out on my iMac running 10.13.4 (17E199) with Safari Version 11.1 (13605.1.33.1.2) and it seems to be working fine for me.

Are those the same versions you are running?

If so, can you try restarting your computer, launching Safari, disabling all of your extensions (Safari Menu>Preferences>Extensions Tab) and see if that helps? Sometimes extensions can get in the way of pages like this.


#3

Hi Zev!

Yep those are the same versions I’m running.

Thank you for the suggestion I have tried it out, but unfortunately it hasn’t had an effect I also tried disabling Malwarebytes just incase. Still stuck with a still image in Safari, it’s strange why it’s working for you and not for me.


#4

Do you have any other extensions or blockers that could affect it? it might be worth making a new user account on your computer, log in, see if it works without any other extensions or programs, and then delete that account afterward. If not, then I would suggest reaching out directly to Canary and see if they have any backend support they can provide.


#5

This happens to me too. I’ve used four different Macs, running various updates of macOS High Sierra, and Canary live streaming is completely unusable in Safari. No extensions/content blockers, just pure Safari as it ships. This has been going on for several months. I just end up launching Chrome just when I want to watch the stream. It loads the first image and is still… then maybe loads another still a few minutes later. Never live video. Always works in Chrome.


#6

Hi Zev, nope no other extensions. I’ve tried the new user as suggested still with no effect.

Thanks for the response idlewilde at least I’m not the only one experiencing this issue. I will get in contact with support and if they have any ideas, fixes or updates on the matter I will post back here!


#7

Hey @JayTheBearded,

Thanks for giving that a shot! I’m sorry you’re still having difficulty. Please link the support team to this topic so they can see the steps you’ve already gone through and that the issue is not localized to you.


#8

Hi Zev!

No problem at all, thanks for trying to resolve the problem. I have linked the support team to the thread so they are able to see the basic troubleshooting and idlewilde is experiencing the same issues.

Thanks again Zev!


#9

Just thought I’d post a small update. No breakthroughs unfortunately, Isaac has passed the information onto their team.

I’ve offered diagnostics but they currently aren’t needed, not 100% sure what the issue is at present but hopefully they find out what the cause is and are able to remedy it.

Isaac suggested just using another browser for now, if there are anymore updates or a fix is implemented I will update here.


#10

Thanks for keeping us updated, @JayTheBearded, glad they are looking into it for you :slight_smile:


#11

As an update to Zev and anyone looking at this post, live streaming in Safari as of today seems to be working a treat! Not sure what has changed or if Canary have been working on something in background, I’ve heard nothing more off them. But hopefully the live streaming in Safari will continue to work!

Thanks to everyone for suggestions and feedback thus far!


#12

Hey @JayTheBearded, great to hear things are working now!


#13

Another update, unfortunately this morning the stream in Safari has stopped working again. Very strange as it was working the best I’ve seen when I last updated the topic! Hopefully Canary support will have an update on this soon.


#14

I’ve had no more updates off Canary as too what is happening with this topic yet.

I’ve since had my MacBook go in for repair so the system was wiped (speaker issue), I then wiped it again upon receiving it back. I’ve tried multiple ‘Empty Caches’, uninstalling any extensions and also resetting Safari all with no avail.

This is making me believe it is a Canary problem, as I’m having the same problem with my late 2012 Mac Mini which I have tried all the same things on. I’ve even tried both on my mobile data tethering from my phone incase it was an issue with my ISP, still no dice.


#16

Update, I’ve been running the current betas of OSX and currently I’m on beta 8. They have been very stable but unfortunately live streaming still isn’t working in Safari 12 14606.1.36.1.6 and of non of the previous betas or the latest stable release.

I’ve visited my local Apple Store who sell all the Canary devices and they’re aware of the issues and are just advising people to use Chrome and Firefox until Canary fix the issue. This store and others have been in contact with the OSX developers because a lot of stores have been getting this complaint from customers for 8 months now who’re telling them it isn’t a Safari or an OSX bug and that it is a Canary bug and that there isn’t much they can do apart from waiting for them to release a fix.

Hopefully Canary will address this with the amount of customers that appear to be having this issue.


#17

Another update, after a ongoing fault on my 2017 MacBook it was replaced with an 2018 MacBook I have tested both iOS 10.13 and now iOS 10.14 with both versions of Safari, the Canary live streaming doesn’t work in either OS or Safari versions.

So with all the investigations I’ve done it must be a Canary fault, especially if Apple have attempted to look into it there end and have confirmed it’s not a problem on there side.

Is there someone from Canary who will responded? Because I have a ticket in as well as this community post and Canary aren’t replying too any and seeming to be refusing to take it on board as a problem. The last respond I had from Canary on the ticket was blaming my install and system, but obviously with multiple re-installs and two different systems that cannot be the case. With other users experiencing the same problem on here and Apple aware of the problem with the cameras they’re supplying for Canary, I’m unsure why Canary are avoiding to fix it.

I’ve offered multiple times to help test issues as I’m experiencing them, but they won’t take me up on the offer. I’m unsure what to do from here because it’s so important that this works,.

I also can’t live stream on my iPhone because I’m running the beta and Canary won’t support it until after the full release which is going to put a lot of iPhone out with not being able to live stream. They are aware of the faults but don’t seem to be addressing them.


#18

Slow and / or absent responses to customers’ difficulties seems to be the standard response and will, unfortunately, be Canary’s downfall on the customer service front.


#19

Totally agree with you Glaw, it makes me wish I’d gone with another company such as Nest or Ring. I would change now but having 7 Canary cameras was a huge investment and they’re letting me and other customers down big time.


#20

Great news everyone Canary have found the fix so live streaming in Safari works as it should again!

In safari’s preferences, autoplay isn’t enabled. To enable this;

  • Go to my.canary.is and try to view live video
  • When you are there, click on the Safari tab on top and go to Preferences
  • Then click on the ‘Website’ tab and click on “Auto-play” on the left
  • You should see ‘my.canary.is’ under ‘Currently open websites’ on the right
  • Click the drop down next to it and switch it to Allow All Auto-Play
  • Then restart Safari.

A special thanks to James K. from Canary support and the engineer who figured out the issue!