Masking picture isn't reflecting camera postition


#1

Hello.

I just recently moved my Canary Flex to another position and therefore had to adjust the masking areas. This is proven to be hard since the app does not show the correct picture, but still showing the old postion. I have done the following:

  • Deleted app and reinstalled
  • Checked that iOS app is latest version (2.15.0 Build 10318)
  • Restaret camera
  • Restartet phone
  • Set Canary to “Away mode” and triggered camera

Nothing has so far helped. Any advice is greatly appreciated!

UPDATE: I went ahead and deleted the camera from the app and reinstalled, and now the “add mask” picture is non existing. It just says “Image preview unavailable”.

IMG_0694

UPDATE 2: I’ll let this post stay in case someone else have similar issue. What I forgot was to trigger recording on away-mode. When this was activated and triggered, the masking picture was updated. I was sure I activated recording, but apparently forgot.


#2

Hey @vegards,

Sorry to hear you are having difficulty.

This is normally the fix that will bring an image there. Would you mind checking your settings and ensuring that this specific Canary device is set to record in away mode? The image is pulled from the most recent item on your time line.

After ensuring that, try triggering an alert again give it a few minutes to activate and send the video to the timeline. Restart the Canary app after it appears on the timeline and then try setting a mask again.

If that still doesn’t work I will have to refer you over to Canary support and would recommend you Submit A Ticket to them with a link to this thread to show what you have already tried.


#3

Just saw your second update, sounds like you got it! Glad it worked out!


#4

Sure did :slight_smile: And with masking, people only sensor and a nice integration into Home Assistant, this is getting really good!


#5

Glad you got it working. We know that this a pain point in the experience and will be looking to improve it in the future.

Best,
Dave