Switched phones, now auto-switching doesn't recognise that I'm home


#1

I recently lost my android phone while on holiday. When I returned home, I purchased a new android device and reinstalled the canary app.

All went well, my canary was picked up and it all just worked… Except, it stopped auto-switching. When I view my address in the app, I see that the app thinks I’m standing in the centre of the geofence yet the app tells me that I’m not at home.

I followed all suggestions in the trouble shooting article for this to no avail.

My device has location services turned on with high accuracy mode.

Can’t help but wonder is this something to do with switching devices…?


#2

Hi @matthazley,

Based on what I see in your account, it doesn’t look like your new phone is allowing Canary to access location services at all. To test this, please try these steps:

  1. Open the Canary app.
  2. Swipe down.
  3. Tap location details.
  4. Tap Edit geofence.
  5. Tap Edit position.
  6. Swipe your finger on the map here several times until the geofence is far from your home.
  7. Tap the green arrow to recenter the geofence to your location.

When you do this, does the map snap back to your home? If not, either Canary doesn’t have permission to access your location services, or your location services are off. You’ll need to adjust your phone settings to correct this. If it does, check if the app is now registering you as home.


#3

Thanks for the reply @angie.

I tried what you suggested, I moved my location and then tapped the green arrow and it immediately took me back to the centre of my green circle.

So I think it can get my location but the app still says I’m not at home… Screenshots attached.


#4


#5


#6

Hi @matthazley,

Very unusual. At this point I’d suggest opening a ticket with our support team so they can investigate more deeply into your issue.


#7

Thanks @angie, will do.